• Gear
  • Shots
  • Photo Craft
  • Video
  • Wide Angle
  • Support
  • New Stuff
  • More
Support SmugMug APIs, Hacks & Tricks Problem with images.get on v1.2.2?

Need some help with your New SmugMug Site?

Dgrin Challenges

They're back! Our latest series of Dgrin Challenges, the OOYCZ Challenges (Out of Your Comfort Zone), is a series of challenges to help you improve your photography by stepping out of your comfort zone and trying something new. Our challenge leader says "Consider it like a photography class with no diplomas.". Get started with OOYCZ by reading the Challenge Guide.

Past DSS Challenge Winners, DSS Challenge Rules, and other important DSS Challenge information is here.

Looking for a little challenge? The Dgrin Mini-Challenges are a great way to challenge yourself. Take a moment to look through past winners and find the current Mini Challenge here.

From Around the Net

Enjoy a few of our favorite articles from around the 'net. If you have something you think we should see, post it here and we'll have a look.

Journeys

Landscapes

Sports

 
Thread Tools Display Modes
Old Oct-10-2012, 04:40 PM
#1
SamirD is offline SamirD OP
Huntsville Car Scene.com
SamirD's Avatar
Problem with images.get on v1.2.2?
I have a script that I paid to develop that will mass collect images from one gallery to another. It does this by looping through the images from an album and collecting them one at a time from the source gallery to the destination.

It worked fine in the past, but today it's doing something weird where it starts to duplicate images after a certain point. The only thing I can think of is an inadvertent change in the api that is causing this problem.

Anyone else using v1.2.2 and getting weird results?
__________________
Pictures and Videos of the Huntsville Car Scene: www.huntsvillecarscene.com
Want faster uploading? Vote for FTP!
Old Oct-11-2012, 01:30 AM
#2
rainforest1155 is offline rainforest1155
with a Heroes touch
rainforest1155's Avatar
Looking at your account details, I can still see attempts at using the outdated 1.2.0 API as well (in combination with phpSmug/2.0.2 which is also outdated). Can you make sure that your script is only using 1.2.2 or higher?
__________________
Sebastian
SmugMug Support Hero

look on the bright side
http://www.SebastianHosche.com
Old Oct-11-2012, 09:00 PM
#3
SamirD is offline SamirD OP
Huntsville Car Scene.com
SamirD's Avatar
Which API key are you referring to? I have two different ones--one of which you can refer to as 'newer' and the other as 'older'.

One of these is probably using the old versions without problems.
__________________
Pictures and Videos of the Huntsville Car Scene: www.huntsvillecarscene.com
Want faster uploading? Vote for FTP!
Old Oct-12-2012, 01:15 AM
#4
rainforest1155 is offline rainforest1155
with a Heroes touch
rainforest1155's Avatar
Quote:
Originally Posted by SamirD View Post
Which API key are you referring to? I have two different ones--one of which you can refer to as 'newer' and the other as 'older'.

One of these is probably using the old versions without problems.
From what I can tell it seems to be the Random image app that's still using that old api.

That said, when did you last use your other app? I don't see any indication that you did so in at least the last 30 days.
I would recommend that you look for a debug option to allow you to get more details on what exactly is happening / going wrong.

Note that I'm no developer or API expert, but if you post more details, others may be able to chime in with suggestions.
__________________
Sebastian
SmugMug Support Hero

look on the bright side
http://www.SebastianHosche.com
Old Oct-12-2012, 07:53 PM
#5
SamirD is offline SamirD OP
Huntsville Car Scene.com
SamirD's Avatar
Yeah, and that ran into a problem where curl couldn't find the image path in the http header, so I had to redo it for that. Then the 6 digit key came along and I turned it off until I had time to work on it. Hence the lack of use. :( The API version may have had something to do it with it too, so I'll update that when I get to coding again.

There's not really a debug option of any sort. I only figured out the API version it was using from reading the raw code.

The reason I think it's the API vs the code is that the API versions are usually working, even when not the newest one. And the function it's using is something that's been around from almost 1.0, so I'm guessing something broke on the API during a recent update. But I'm not sure. I'm sure someone else out there is using the same version and method, so I'm hoping to get some feedback.
__________________
Pictures and Videos of the Huntsville Car Scene: www.huntsvillecarscene.com
Want faster uploading? Vote for FTP!
Old Oct-16-2012, 04:15 PM
#6
devbobo is offline devbobo
LR whisperer
devbobo's Avatar
There has been no API updates recently.
__________________
David Parry
SmugMug API Developer
My Photos
Old Oct-16-2012, 09:42 PM
#7
SamirD is offline SamirD OP
Huntsville Car Scene.com
SamirD's Avatar
Quote:
Originally Posted by devbobo View Post
There has been no API updates recently.
Thank you for the information. Any reason why images.get on v1.2.2 might be returning something other than a full array of images? Something usually doesn't just break like this when it was working fine before.
__________________
Pictures and Videos of the Huntsville Car Scene: www.huntsvillecarscene.com
Want faster uploading? Vote for FTP!
Old Oct-16-2012, 11:01 PM
#8
devbobo is offline devbobo
LR whisperer
devbobo's Avatar
How about providing some specific information like AlbumIDs instead of open ended questions ?
__________________
David Parry
SmugMug API Developer
My Photos
Old Oct-19-2012, 09:22 PM
#9
SamirD is offline SamirD OP
Huntsville Car Scene.com
SamirD's Avatar
Okay, let's just repeat what I did and see what happens. Keep in mind this used to work fine, and did even just a few months back.

Goto www.huntsvillecarscene.com/smug
Choose Mass Collect Images
Enter in the destination account information and leave the source blank
Use this link for source: http://natureshots.smugmug.com/gallery/25790523_254Zvv
And use your destination gallery link for the destination.
Click on 'start collecting' and watch for a duplicate filename in the images collected--that's the problem.

The code is simply enumerating the array of images, so I'm guessing the problem is in there somewhere. I would suspect the code except that it's worked very well in the past for galleries even much larger than this one. Any assistance appreciated.
__________________
Pictures and Videos of the Huntsville Car Scene: www.huntsvillecarscene.com
Want faster uploading? Vote for FTP!
Old Oct-20-2012, 06:07 AM
#10
David PL is offline David PL
Big grins
Quote:
Originally Posted by SamirD View Post
Okay, let's just repeat what I did and see what happens. Keep in mind this used to work fine, and did even just a few months back.

Goto www.huntsvillecarscene.com/smug
Choose Mass Collect Images
Enter in the destination account information and leave the source blank
Use this link for source: http://natureshots.smugmug.com/gallery/25790523_254Zvv
And use your destination gallery link for the destination.
Click on 'start collecting' and watch for a duplicate filename in the images collected--that's the problem.

The code is simply enumerating the array of images, so I'm guessing the problem is in there somewhere. I would suspect the code except that it's worked very well in the past for galleries even much larger than this one. Any assistance appreciated.

It looks like the source album you have linked above has several duplicates of the same files itself. That would most likely be why your code would be collecting duplicates if it is just collecting every image from that album. Here is an example from a quick look at your linked album of two images in that album that are the same (both are "IMG_0001.jpg" and appear to be the same image):

1) http://natureshots.smugmug.com/Cars/...DPkvL&lb=1&s=A

2) http://natureshots.smugmug.com/Cars/...KbTh4&lb=1&s=A
Old Oct-21-2012, 12:16 AM
#11
SamirD is offline SamirD OP
Huntsville Car Scene.com
SamirD's Avatar
Quote:
Originally Posted by David PL View Post
It looks like the source album you have linked above has several duplicates of the same files itself. That would most likely be why your code would be collecting duplicates if it is just collecting every image from that album. Here is an example from a quick look at your linked album of two images in that album that are the same (both are "IMG_0001.jpg" and appear to be the same image):

1) http://natureshots.smugmug.com/Cars/...DPkvL&lb=1&s=A

2) http://natureshots.smugmug.com/Cars/...KbTh4&lb=1&s=A


Thank you so much! It never occurred to me to check the source album for dupes.

Great to know the script is still working fine.
__________________
Pictures and Videos of the Huntsville Car Scene: www.huntsvillecarscene.com
Want faster uploading? Vote for FTP!
Tell The World!  
Similar Threads Thread Starter Forum Replies Last Post
7d Frame Capture Problem Rob Pauza Cameras 12 Apr-19-2012 06:17 PM
D80 problem Giphsub Cameras 14 Jan-17-2008 05:20 AM
Hit Counter Problem twincitiesphoto SmugMug Pro Sales Support 0 Dec-30-2007 06:40 PM
Back Focus Problem rajul Cameras 4 Nov-18-2007 04:00 AM
Weird problem with mapping docwalker SmugMug Support 13 May-30-2006 04:56 AM


Thread Tools
Display Modes

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump